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About this guide
This guide is designed to provide a quick introduction to Promodag Reports for Microsoft Exchange, and
it describes steps from getting started to producing the first report.

For more details about specific features of Promodag Reports, please refer to the online Help system.

Introducing Promodag Reports

Promodag Reports is an advanced and cost-effective reporting tool that enables administrators and IT
managers to obtain valuable information about all aspects of their email system.

With its powerful and easy-to-understand features, Promodag Reports produces comprehensive
reports that you can rely on to ensure better security, business continuity, and to get a better under-
standing on the email activity within your organization.

Promodag Reports is easy to install and configure. Reports use native Office 365 data sources. The
product collects and stores the necessary data into a SQL Server Express LocalDB or SQL Server data-
base. You can choose from over 30 ready-made report templates and publish reports to various des-
tinations in different formats. All operations can be easily automated and scheduled so you can set up
the product and forget about it.



Getting started with Promodag Reports

5

How does it work?

Office 365 environments: schematic system lay-
out
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Chapter 1 - Prerequisites

A - Computer requirements

The 'Promodag computer' is the computer on which Promodag Reports is installed.

Promodag Reports can be installed on amachine running a supported desktop or server operating sys-
tem. It is not recommended to install it on a strategic element of your environment, for example a GC
server or an Exchange server.

1 - Computer hardware and software requirements

l Computer: A Core i3 Intel Processor with 4 GB of RAM or an equivalent Virtual Machine.
l Supported operating systems: A 64-bit version of Windows10/Windows Server2016 toWindows
11/Windows Server 2022. Core versions of Microsoft Windows Server are not supported.

l TheWindows Remote Management (WS-Management) service should be enabled and set to
Automatic (Delayed Start).

2 - Internet access

The computer must have access to the Internet and the endpoints whose list is regularly updated by
Microsoft must be reachable for customers using Office 365 plans, including Government Community
Cloud (GCC).

B - Certificate-based authentication to Office 365

If your company's security policy doesn't allow you to use an account and password to access Office
365 or if you use MFA, you can skip theUser-based authenticationmode and use the Certificate-
based authenticationmode instead. You can make this choice in the Configuration Wizard or in the
Office 365 configuration tab of Tools > Options.

1. Create the certificate and the Promodag Reports Application

Please follow these steps to create the Promodag Reports Application, the certificate and register them
in Azure AD:

Prerequisites

The computer's operating system version must be greater than or equal to Windows 10/Windows
Server 2016.

The AzureAD PowerShell module should be installed on the computer. It if is not, please proceedwith
these steps:

1. Click and search for PowerShell > Windows PowerShell and run it as administrator.
2. Install the AzureADmodule: Install-Module AzureAD -Scope CurrentUser

Create the certificate and application using the provided script

These steps will enable you to create a self-signed certificate valid for two years in the same directory as
the script, and an application named "Promodag Reports Application" in Azure to access your tenant.

1. Navigate to the script directory: C:\Users\Public\Documents\Promodag\Reports\  
2. Run the script: .\CreateRepexApp.ps1
3. Enter certificate password at prompt andwrite it down.

https://docs.microsoft.com/en-us/microsoft-365/enterprise/urls-and-ip-address-ranges?view=o365-worldwide
https://docs.microsoft.com/en-us/microsoft-365/enterprise/urls-and-ip-address-ranges?view=o365-worldwide
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4. The script will proceed and you will be prompted to sign-in to Office 365. Use a Global Admin-
istrator account.

5. A certificate valid for 2 years has now been created in the script directory with the name "Rep-
exAppCertificate.pfx". The application has been created in Azure with the name "Promodag
Reports Application".

6. The script displays the summary information to be used in Promodag Reports: Application ID
and certificate path, plus a link to connect to Azure and authorize the newly created application.
This information is then saved into a file in the current directory.

2. Authorize this new application in Azure

Grant admin consent

1. Paste the link displayed in a web browser to connect to Azure. The Promodag Reports Applic-
ation | API permissions page opens.

2. ClickGrant admin consent for <name of your Office 365 tenant>.
3. Review the permissions granted to the application (see the help file for detailed information).

Optional: You can delete the self-signed certificate and use your own if you prefer. See the help file on
how to do it.

Assign the Global Reader role to the Promodag Reports Application

Please follow these steps to assign the Global Reader role to the Promodag Reports Application in Azure
AD:

1. On the Azure AD portal at https://portal.azure.com/, under Manage Azure Active Directory,
click View.

2. On the Overview page that opens, under Manage, select Roles and administrators.
3. On the Roles and administrators page that opens, find and select the Global Reader role by click-

ing on the name of the role (not the check box) in the results.
4. On the Global Reader | Assignments page that opens, click Add assignments.
5. In the Add assignments page that opens, click Nomember selected under Select member(s)*

and select the previously created Promodag Reports Application. You can use the Application ID
set in the Office 365 configuration tab of Tools > Options to identify it if several Promodag
applications are listed.

6. When you're finished, click Assign.
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7. Back on the Global Reader | Assignments page, verify that the Promodag Reports Application
has been assigned to the Global Reader role.

3. Apply "Promodag Reports Application" settings to Promodag Reports

Please make sure that you have retrieved the following information the first step:

l Application ID,
l Certificate path,
l Certificate password.
1. In Promodag Reports, go to Tools > Options, Office 365 configuration.
2. Select Certificate-based authentication.
3. Enter the Application ID, Certificate file path and Certificate password in the corresponding

fields.
4. Click the Check validity link to verify the certificate expiration date.  
5. Click the Check connection links to verify that Promodag Reports can connect to your tenant

using the Azure application and the certificate.

C - User-based authentication to Office 365

Promodag Reports can collect information from your Office 365 tenant through a user with specific per-
missions. It is possible to use an existing account; however, we recommend creating a dedicated user
for that purpose. This account must not be subject to multi-factor authentication (MFA). You can make
this choice in the Configuration Wizard or in the Office 365 configuration tab of Tools > Options.

1. Create a user account for Promodag Reports

l Sign in to Microsoft 365 Admin Center as an administrator.

l ClickUsers > Active users and select Add a user.
l Choose a Display name and a user name, for example 'Promodag user'.

2. Assigning the appropriate roles to the Office 365 Promodag user
l Sign in to Microsoft 365 Admin Center as an administrator.
l Click Admin > Exchange to open the Exchange Admin Center.
l Click Roles > Admin roles and then click Add role group.
l In the Set up the basics window that appears, enter a name and a description pour this new
group, for example 'Promodag Reports Role Group'.

l In Permissions, select the Mail Recipients and View-Only Recipients roles.
l In Admins, add the Promodag user.
l Click Add role group.

3. Allowing reports on mailbox content

Some additional conditions must be met to allow Promodag Reports to retrieve the content of mail-
boxes when running the reports of the Mailbox Content category:

l The Promodag user must be assigned a user mailbox and therefore an Office 365 license.
l Grant the ApplicationImpersonation role to the Office 365 Promodag user. To assign this role,
please edit the role group created at the previous step, open the Permissions tab and add the
ApplicationImpersonation role.

l If you use Modern Authentication with Office 365, authorize Promodag Reports in Azure AD. To
perform this task, open the application, go to Tools > Options, test your connection in Office 365
configuration and follow the instructions provided .
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Note : The ApplicationImpersonation role is about to be deprecated (May, 2024) and it will no
longer be possible to run reports on mailbox and public folder content.

D - SQL Server requirements for Promodag Reports Enterprise edition

1. Supported versions

Promodag Reports supports all editions of Microsoft SQL Server from SQL Server 2008 to SQL Server
2022.

SQL Server Express (2008 to 2022)may be usedwith Promodag Reports Enterprise edition; however,
database size is limited depending on the version (10 GB for SQL Server 2008 R2/2022 Express and 4
GB for SQL Server 2008 Express).

2. Permissions

The Promodag account must have been granted the db_owner role on the Promodag Reports data-
base. It must also have the public and db_datareader roles on the TEMPDB database.

The ability to create databases requires specific SQL permissions (CREATE DATABASE).
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Chapter 2 - Getting started

A - Evaluating the product

You may evaluate Promodag Reports for a period of up to 45 days from first installation. The only
other limitation is that your reports on e-mail traffic can only cover a maximal period of 15 con-
secutive days.

You can indeed only import up to 15 consecutive days of Office 365 message tracking files in evaluation
mode, which explains the latter restriction.

There is no limitation to the number of report templates you can use - all options being available, dur-
ing your 45-day evaluation period.

B - Installing the application

Note: Please make sure that your workstation complies with all points listed in Workstation
requirements before proceeding with the installation process.

Installing Promodag Reports
a. Go to https://www.promodag.com/ to download Promodag Reports.
b. Choose a temporary directory to store the installation package.
c. Double-click the installation package to start the installation process.
d. Simply follow the instructions of the installation wizard.

For more information about default paths for installation and settings, see the help file.

C - Initial setup

Starting the application

From the Start Menu, select Programs > Promodag> Promodag Reports 14 to start Promodag Reports.

The configuration wizard provides a user-friendly interface to start with Promodag Reports. It auto-
matically appears when you run the software for the first time, and guides you through the first con-
figuration of the product.

https://www.promodag.com/
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It provides you with instructions on:

1. Evaluating or licensing the product,
2. Creating a new Promodag Reports database,
3. Configuring a connection to your Office 365 tenant,
4. Selecting data sources for traffic and storage size reports, 
5. Starting the data import process.

1. Evaluating or licensing the product

This window lets you carry on using Promodag Reports in evaluation mode or apply a valid license to the
database.
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2. Creating a new Promodag Reports database

Promodag Reports requires a database in order to store the data it collects from Microsoft Exchange. It
will then use this data to generate reports. It is possible to create multiple databases.

To create a new database, select the type of your messaging environment, and the type of database
that best suits your needs.

Exchange Organization type
l Office 365: The messaging system is hosted by Microsoft. Microsoft Exchange Online is an email,
calendar and contacts solution delivered as a Cloud service and it is part of the Office 365 suite.

l Hybrid deployment: Hybrid deployment is a mixed environment: part of the messaging system is
hosted in an Office 365 tenant, but the company has kept some Exchange servers on-premise.

l On-Premises: Administrators run the messaging system on their own servers, in their own com-
pany.

Select Office 365.

Database type

SQL Server Express LocalDB
l Best suited for small Exchange organization.
l Usable with all editions of Promodag Reports.
l The physical size limit set by Microsoft to LocalDB database files is 10 GB (10,240 MB).
l Microsoft SQL Server LocalDB 2017 is installed with Promodag Reports.
l Nomulti-user access.
l The database file should be located on the same computer as Promodag Reports.
l Easy upgrade to SQL Server.

Microsoft SQL Server
l Best suited for medium or large Office 365 tenants (more than 1,000 mailboxes).
l Requires the Enterprise edition of Promodag Reports.
l The database size is only limited by disk space on the SQL Server.
l Multi-user access.
l Performance is determined by the power of the SQL server.
l An additional SQL Server license (not provided)may be required.

The LocalDB format is recommended for evaluating the product, for it does not require anything else.

Choose a name for your database. For SQL, enter the name of the server without \\, and then the
name of the instance if applicable.

ClickNext to confirm your settings andmove on to the next step.
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3. Configuring a connection to your Office 365 tenant

If you have subscribed to an Office 365 GCC High or DoD plan, choose your Office 365 Cloud from the
drop-down list.

You can choose between two sets of settings that allow Promodag Reports to access Office 365
resources:

l Certificate-based authentication (recommended): Promodag Reports must be published
as an application in Azure. In this context, the permissions are those that have been granted to
the application and not to a user. To create this standard Promodag Reports Application and the
linked certificate, see "Certificate-based authentication to Office 365", on page 6. To create a cus-
tom Azure application manually, see the help file.
l Pros:

l No specific user account andmailbox are required, which completely eliminates the
problem of password expiration.

l No Office 365 license is required.

l Import of Office 365 licenses.
l Cons: Permissions are granted through an Azure role.

l User-based authentication: The permissions are those granted to the PromodagOffice 365
account. For more information about the required permissions, see Creating a Promodag user for
your Office 365 tenant.
l Pros: Permissions can be granted to the account in a more granular way.
l Cons:

l An Office 365 license for a user andmailbox are required.
l If the password regularly expires, it must be updated in Promodag Reports.
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l This mode is incompatible with MFA.

l No import of Office 365 licenses.

ClickNext to confirm your settings andmove on to the next step.

4. Selecting data sources for traffic and storage size reports

Data sources for traffic reports

Promodag Reports will create and then import Office 365 message tracking files to generate traffic
reports. Message tracking data is only available from Office 365 for the past 10 days.

Data sources for storage size reports

The size of mailboxes is selected by default. If you have public folders in the Cloud, select Public folder
size.

Click the Next button to confirm your settings andmove on to the next page.
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5. Starting the import data process

Processing imports

Click Finish to start importing data. The complete process includes all previously configured steps and
can take some time depending on your selections.
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Promodag Reports

1. Imports recipients from Office 365,
2. Creates message tracking files,
3. Imports message tracking data,
4. Imports storage size data.

Each operation finishes off by displaying an operation report dialog box. A trace file is also recorded and
can be used to troubleshoot possible errors or resolve various configuration issues. If you need to do so,
use the Consult Trace Files option to view the content of the last trace files.
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Chapter 3 - Using reports

A - How to find your way?

Promodag Reports includes about 30 report templates adapted to Office 365 that you can use to create
your own custom reports.

1. Report templates

To open a template, you can either

1. Use the Templates menu.
2. Use the Report Explorer, on the left pane of the main window. It can be hidden or displayed by

clicking the icon.

Before you start using the product, we suggest you open our List of reports templates in the embedded
help file.

Templates are grouped in categories, such as Storage or Billing for example. These categories appear
as main nodes in the Report Explorer and they cannot be modified. The names of these categories are
meant to help you find your way among templates. Each entry comes with a short description.

Graphical reports are distinguished from tabular reports in the Templatesmenu as well as in the
Report Explorer by a specific icon.

EXAMPLE

l A template that would let you generate a report showing the size of public folders is likely to be
found in the category calledStorage. If you open that category, you will find a template called
Public Folder Storage Information.

l Should you likewise need to produce a report showing the top 10 email senders in your organ-
ization, open the category calledMailbox Traffic. If you open that category, you will find a tem-
plate called Mailbox by Traffic Level.

2. Canned reports (Favorites)

The software is delivered with a number of ready-to use custom reports, for example: 'What are the 10
largest mailboxes'. These canned reports are available on the Favorites menu and they are grouped in
custom categories based on the main use cases of the product: Traffic Analysis and SLA
Reporting, Compliance, Capacity Planning and Exchange Migrations, Chargeback.

You can rename these sample reports or delete them at will. You can also rearrange the existing tree or
create your own hierarchy in the Favoritesmenu.

B - Creating new custom reports

1. Selecting a valid reporting period

Period tab and data sources

Many report templates include a Period tab: all traffic reports and some reports on storage size. These
templates share in common the use of data that must previously be imported into the database.
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What reporting period can be selected?

The time range you select in the Period tabmust always be covered by matching data imports.

EXAMPLE

Requesting a report on mailbox traffic for January until June last year will not work if you have only star-
ted to import message tracking files of this year. If you do so, you will get a message to inform you that
'No data was found for the selected period'.

Note: In evaluation mode, it is only possible to import 15 days of data: as a consequence, it is
also only possible to report on that same time period.

For more information on the limitations of the evaluation mode, see Evaluating the product.

2. Selecting recipients

Selection tab and recipients

All report templates include a Selection tab. This feature lets you include recipients whose traffic, con-
tent or storage must be displayed in the report.

A recipient can be amailbox, a distribution group, a public folder or a mail contact.

Recipients are imported with most of their attributes into the database, which lets you select them
using the attribute of your choice in the Selection tab.

EXAMPLE

Mailboxes can be selected by Country, or Department, or Employee ID.
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What recipients can be selected?

Each report template focuses on a specific aspect of the messaging system. As a consequence, the avail-
able Selection tabs differ depending on the scope of the report template.

EXAMPLE

A report template focused on mailbox traffic will let you select mailboxes, whereas a report template
dedicated to public folder content will let you select public folders only.

Some transverse templates like Find Specific Messages, that is focused on messages, will let you select
different recipient types:mailboxes, or distribution groups, or public folders.

Excluding recipients

Click the button to exclude recipients from the report using the same principle.

3. Selecting correspondents

The 'correspondents' are those who sent messages to or receivedmessages from your selection of recip-
ients.

The vast majority of traffic report templates include a Correspondents tab. This feature lets you filter
the correspondents of the recipients previously selected in the Selection tab.

The most usually available option allows you to select correspondents by address type.

l To select all internal correspondents, select: Correspondent type, Is any of, Internal.
l To select all external correspondents, select: Correspondent type, Is any of, External.
l To select all application agents, devices etc. that have an SMTP address but nomailbox, select:
Correspondent type, Is any of, Unidentified local recipient.

EXAMPLE

You may want to select correspondents from specific SMTP domains, for example the gmail.com, yahoo
and hotmail correspondents of the selection of mailboxes you have just checked in theSelection tab.
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4. Selecting the right detail level

Many report templates include a Content tab with Detail level options. This feature is aimed at focus-
ing the report at different levels.

EXAMPLE

A report template on recipient traffic such as General Mailbox Traffic includes three detail levels: Totals
only, Recipient andMessage subject line. if you select Totals only, it will merely display a cumulated
total of all messages sent/received by the selected recipients, whereas it would display each single mes-
sage if you had selectedMessage subject line.

The same principle applies to all other templates that have a Detail level option: the more you go down
the list, the more detailed the report will be.

C - Saving custom reports

1. Saving and reloading a report with its options

To create and save a new custom report, select a report template from the Templates menu, and select
the options of your choice. You may also record specific selection settings separately if you plan to reuse
them in other reports.

l Click the Save options button at the bottom of the report interface to save the option file.
l Click the Load options button to reload it once the report interface is open.

2. Adding a report to the Favorites

Make your own custom reports available in the Favorites menu by selecting the 'Add to Favorites
menu' check box before saving them.
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D - Previewing, exporting, publishing and e-mailing reports

A report can either be previewed on screen, exported to various file formats, published to a SharePoint
document library or automatically attached to an e-mail and sent to a recipient of your choice.

1. Previewing reports

The default output is 'Screen'. It is recommended to use it when generating a report for the first time,
so that you can reload your options and adapt them if necessary.

2. Exporting reports

Use the File > Export Report option once the report is available for preview on screen.

Available formats

Reports can be exported to different file formats: CSV, PDF, XLS, XLSX, RTF, HTML, MHT.

3. Publishing reports

You can export reports

l To your Intranet: Export reports as PDF or HTML files to the web root of your intranet.
l To a public folder: Select the 'Exchange folder' output option.
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l To SharePoint: Select the SharePoint output option. The default server and document library can
be selected in the Export tab of Tools > Options.

4. E-mailing reports

All reports can be emailed to specific recipients, by selecting the Email output option. Moreover, the Indi-
vidual reports tab allows you to email reports to all mailboxes selected in the report.

Support

This page provides an overview of Promodag support resources for our existing users and newcomers
evaluating the product. Alongside a suite of on-line resource tools focused on addressing common user
issues, we also provide a dedicated support system.

Self-help resources

The quickest starting point for your support needs is to consult our on-line resource tools on our sup-
port page (https://www.promodag.com/support).

Submitting a Support Request

Our customer support team will respond to requests from both users evaluating the product and cus-
tomers with a validmaintenance contract.

Support requests can be submitted either …

l Via our contact form: https://www.promodag.com/contact-us/
l Via email at support@promodag.com or use Help > Technical Support Request from the product’s
menu system.

l Or by phone: +33 1 45 73 49 96 or Toll Free (from USA only): (844) 311-5003.

We normally respondwithin 2 hours, but please allow 24 hours for us to respond to account for dif-
ferences in international time zones. Our office hours are 10 AM to 7 PM UTC+1 (Paris), Monday to Fri-
day.

https://www.promodag.com/support/
https://www.promodag.com/support/
https://www.promodag.com/contact-us/
mailto:support@promodag.com?subject=Support request for PROMODAG Reports
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