How to unlicense an old server, license a new one and import data from it

If you wish to remove old servers, add new ones and import data from them, please follow these steps:
  • Run the File > Import Directory Data option, check the Full re-import radio button and click 'Start Import'. PROMODAG Reports will discover your new server.
  • Go to Help > License. Unselect your old server and select the new one. Click 'Apply' and then OK.
  • On the File menu, point to Import Message Tracking Data.
    1. Select your new server(s) in the left pane and push it to the right pane using the => button.
    2. Click the Server Properties button. Verify that all settings are correct, particularly the path to the message tracking directory.
    3. Check the date in the Next import from field and modify it if necessary. If your license is valid for a given number of server, it will not be possible to import message tracking files from more servers for the same date (if you removed your old servers on May 1,2017, you will only be able to import message tracking files from the new ones from May 2, 2017). If , you attempt to do so, you will obtain a 'Bad license check' or 'The maximum number of authorized imports for that date has already been reached' error message.
    4. Click the 'Apply' button.
  • On the File menu, point to Import IIS Data (if applicable).
    1. Select your new server(s) in the left pane and push it to the right pane using the => button.
    2. Click the Server Properties button. Verify that all settings are correct, particularly the path to IIS log directories.
    3. Check the date in the Next import from field and modify it if necessary.
    4. Click the 'Apply' button.
  • On the File menu, point to Import Storage Size Data  (if applicable).
    1. Select your new server(s) in the left pane and push it to the right pane using the => button.
    2. Verify that all settings are correct.
    3. Click the 'Apply' button.
  • On the Tools menu, point to Task Automation.
    1. If you have created one, select your import batch file (DailyImport.prb, for example) and then double-click the 'Import Message Tracking Data' action in the right pane.
    2. Make sure that your new servers are selected by default: the 'Process pre-selected servers for import' radio button should be selected. If you explicitly selected Exchange servers in the right pane, clear that list and select your new servers.
  • Finally, verify each of your custom reports and remove/replace any server selection that may exist.

Add Feedback