Question:

What is the procedure to move your application onto a new console?

Answer:

The procedure to move PROMODAG Reports from a computer to another one is pretty straightforward:

1. On the first computer,
  • Save the content of the %PUBLIC%\Documents\Promodag\Reports\10\Batches and \Selections folders on a public share, or a USB key; if you use a local Access database, make a backup as well.
  • Uninstall PROMODAG Reports and delete the existing scheduled tasks.
2. On the new computer,
  • Install the latest release of PROMODAG Reports;
  • Make sure a supported version of MAPI client libraries - preferably Outlook 2010 or 2013 (32-bit only) - is also installed;
  • Move the local Access database (if applicable) from the old workstation to the new one in %PUBLIC%\Documents\Promodag\Reports\Databases;
  • Move the Promodag\Reports\10\Batches and \Selections folders you copied from the old workstation to the new one;
  • Start PROMODAG Reports;
  • Reconnect the SQL database or open the local Access database;
  • Recreate the scheduled tasks using the Tools > Task Automation option (do not directly use the Windows Scheduler);
  • Go to File > Import Message Tracking Data and reselect your Exchange servers for data import. It will assign them to the new console.
  • Go to File > Import IIS Data and repeat that operation (if applicable);
  • Go to File > Import Storage Size Data and repeat that operation (if applicable).
See also:

Add Feedback